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Welcome to dx.factory V1.0

Introduction
dx.factory is a cross platform Librarian for the Yamaha DX7 series of synthesizers, that allows you to organise
your DX data from the comfort of your computer.

dx.factory has been written by me, Derek Cook, and is available exclusively as a free download
from www.xfactory−librarians.co.uk. The free version is fully functional apart from the save and export
features (including MIDI export) are disabled.  This allows you to evaluate the features of dx.factory to see if
you like it before buying it. If you wish to use dx.factory and enable the save and export functions you will
need to register dx.factory and pay a shareware registration fee.

dx.factory was written as I have never been able to find a librarian for the DX7II that supports performance
mode in the way that I want.

I am greatly interested in user feedback for shaping future versions of dx.factory. Comments and bug reports
on the current features of dx.factory and requests for future features can be sent
to dx7@xfactory−librarians.co.uk, or they can be posted in the DX7 forums of www.xfactory−librarians.co.uk.

dx.factory is programmed in Java, so it is capable of running on any platform that supports the Java version
1.4 and above.

The application has been developed and tested in JRE 5.0 running on a PC with the Windows XP operating
system.

The screen shots you see in this manual have been taken with dx.factory running upon JRE 5.0. The look and
feel of the application will vary depending upon your target JRE and computer platform, so don't worry if
dx.factory looks slightly different upon your system.
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Getting Started
Installation of dx.factory is quite staight forward, but as dx.factory is a Java application, it requires a Java
Runtime Environment (JRE) to be installed on your computer.

To get up and running with dx.factory you will need to:

Install a JRE if you do not already have one (V5.0 or later)• 
Install the dx.factory software• 

Installing these two components is covered in the next section.

The minimum JRE version is  JRE 5.0. Just to confuse everybody, the new version of Java is called 5.0, but it
is the next release following 1.4. Indeed if you install JRE 5.0 and look at the installation directory, you will see
the version number is 1.5. Sun must have their reasons for a quantum leap in the version number, but I'm
even more confused as to why the installation directory numbering is not consistent!

PC Requirements
Any PC running either Windows 98, Windows ME, Windows 2000 or Windows XP should do the trick

Macintosh Requirements
A Macintosh running the Macintosh OSX V10.2 operating system or later is required. OSX has the Java
Runtime Environment (JRE) built in to it, but you will need to ensure that you have the latest version.

Unfortunately, Apple have no plans to support the latest JRE in the "Classic" Mac OS, so dx.factory will not
run on older MAC Operating Systems.
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Installing dx.factory
Basically, you need two components on the system to run dx.factory:

A Java Run Time Environment (JRE), J2SE 1.4 or above• 
The dx.factory application itself, which is in the dxfactory.zip distribution file• 

dx.factory does not come with an installer, as I have not gotten around to setting one up yet. And to be
honest, installation is just a matter of installing a few files onto your hard disk.

Java Run Time Environment
To run dx.factory you need Java 2 Standard Edition (J2SE) Version 5.0 of the Java Run Time Environment
(JRE), or a later compatible release. 

Installing a JRE for the PC

PCs are not provided with a J2SE JRE by default, so unless you are running other Java applications or web
browser applets that need it, the chances are you won't have it.

To check if you have the correct JRE (if any) you need to go into the Windows Control Panel.

From the Task bar's "Start" button you can do this by selecting the "Settings" menu item, followed by the
"Control Panel" sub menu item.

Once you're in the Control Panel, look for an icon called "Java". If you are running Windows XP then you will
need to select the Classic View (by default the XP shows a Category View).

If you cannot find the Java icon in the control panel then you need to install a JRE.

If you have an earlier version than 5.0, you will need to upgrade. To check the version you have, double click
the Java icon. How you check the version number in the Java control panel applet is dependent upon the
version, but if you hunt around you should find the version number.

As Sun keep reorganising their site, and rather than trying and keep these instructions up to date, please
visit www.xfactory−librarians.com/java for details on how to get the latest JRE.Once you have the download,
install it by double clicking on the file and follow the installation prompts.

Installing a JRE for the Macintosh

MacOS X 10.2 or later is required, and Java V5.0 or later is required.

MaxOS X 10.3 with the latest updates and the latest Java V5.0 update is recommended.

You should check that you have latest MacOS X release and latest Java VM version installed by running the
"Software Update" utility.

dx.factory cannot run on earlier versions of the "classic" Mac OS.

dx.factory Application
dx.factory is distributed as a standard Java JAR file.

(A JAR file is a Java Archive, which contains all the components required to execute the application).

Simply copy the file called dxfactory.jar from the dxfactory.zip distribution file to the location upon your hard
drive where you wish it to be installed.

Along with the dx.factory JAR file, dx.factory also requires the JH.JAR file, which provides the online help
support, and the DOM4J.JAR file, which provides XML support.

JH.JAR and the DOM4J.JAR files are included in the dxfactory.zip file, and all you need to do is copy the
JH.JAR and DOM4.JAR files from the dxfactory.zip distribution file to the same directory where you placed
dxfactory.jar

That's all that's needed for basic operation of the application.

For the PC, it's possible to create shortcuts in the normal manner to the dxfactory JAR file, so you can make it
accessible in the way that suits you. E.g. I have a shortcut on my desktop.
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Installing MIDI Extensions for MacOS X
If you wish to use the new MIDI support provided by dx.factory once you have registered dx.factory upon
MacOS X, you will need to the PLUM−STONE MIDI extension.

This extension provides MacOS X Java programs access to all CoreMIDI devices, using standard Java
classes.

You can download PLUM−STONE from the Plumstone website.

Then copy the supplied jar file to the /Library/Java/Extensions directory within the JRE installation.
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Registering dx.factory
You need to register dx.factory to allow MIDI data to be exported to the DX7 and for data to be saved to your
computer. Essentailly dx.factory is released as "try before you buy" shareware. Prior to registration, you can
run the program and load, import data and manipulate data to see the potential value of the program, but you
will need to register and purchase a license file in order to save and export data.

Registration of dx.factory costs $50 USD.

My preferred payment mechanism is via Paypal, although I will consider other payment mechanisms as long
as you are prepared to pay any additional costs associated with the transaction, and as long as it is not too
laborious. If you wish to use an alternate payment mechanism then please
email registration@xfactory−librarians.co.uk with the details. Please note that if I have to deal with a lot of
registrations in one go, priority will be given to registrations using Paypal as the payment mechanism.

To start the registration process you will need the serial number of your copy of dx.factory.

To find your dx.factory serial number, select the Register ... option from the Help menu, and you will see the
following dialog box.

This is the dialog screen for an unregistered version, which is showing:

That the copy is unregistered• 
The Serial Number that you need to make a note of • 
That no license file has been found• 

NB: The serial number given in the above dialog is an example. You will need to provide the one being
reported upon your system as the serial number will vary from system to system To register dx.factory you
need to make a note of the serial number from the registration dialog box and make a paypal payment of $50
USD to the following email address:

registration@xfactory−librarians.co.uk

Don't forget to include the serial number in the Paypal transaction details. Once I have received payment, I
will issue the license key, which is generated using the serial number you have provided.

License Keys
Once I have received payment, I will generate a license key and send it back to you.

Please note that occassionally I work away from home (with limited or no Internet/email access), so please
allow up to fourteen days to receive registration details or your license key before chasing me.

Once you have received the license key file (called license.jar), simply extract it from the zip file it comes in
and place it in the same folder where you placed the main dx.factory application.

I send out the license key zipped up because some email service providers do not allow JAR files to be sent
as attachments.

Please note that whilst dx.factory is freely distributable, the license key I send you is not. Please respect this
and the amount of effort I have put into developing this application.

Please note that the license key may become invalidated if you do certain things to your machine
configuration:

If you do invalidate your license key you will have to apply for a new one. This will not cost you any extra.

Whilst I appreciate that some people may view this as an inconvenience, I have done this to make pirating of
the license keys by simple copying a little more difficult.
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Running dx.factory
Simply double click on the program icon for the program either in an Explorer shell, or from the desktop if
you've placed a shortcut there.

Please note that the start−up of the program (as for any Java Program) is a little slower than a "native"
application.

During start−up, a "Splash Screen" is shown. This stays visible until a few seconds after the program has
loaded and is ready for use, but can be dismissed at any time by clicking on the Splash Screen.

In operation you may occasionally notice a pause in the operation of dx.factory as a new resource is loaded
(e.g. the first time a file dialog is accessed, it needs to be loaded from disk). Other than that you shouldn't
notice any adverse speed problems, as Java is pretty zippy on modern computers.

dx.factory remembers the size and position of the main window between sessions, so the main window will be
sized and positioned as you left it the last time.

You can also startup dx.factory from a command (MsDOS) shell. Simply change directory to where dx.factory
is located and type the following:

java −jar dxfactory.jar
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The dx.factory Window
The main dx.factory window looks like this

The dx.factory user interface is a Multiple Document Interface (MDI), which allows you to have more than one
file open at a time.

The interface is divided into the now familiar layout of (from top to bottom):

The Title Bar• 
The Menu Bar• 
The Tool Bar• 
The Desktop• 
The Status Bar• 

The dx.factory Window 7



Menu Bar
The dx.factory menu bar provides a means of selecting common operations; typically those that affect a
complete file, or those that don't fit naturally upon a context sensitive popup menu.

Keyboard Shortcuts are provided for common operations.

dx.factory also provides context sensitive popup menus, which are accessible by right clicking over data
shown in a Child Window. Naturally the contents of the popup menus varies according to the type of data over
which the menu was popped up.

Main Menu Headings

The following menu headings are available.

File Menu• 
Edit Menu• 
View Menu• 
MIDI Menu• 
Tools Menu• 
Window Menu• 
Help Menu• 
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The File Menu

The File menu provides the following options:

New ...

Shows the Create New File Dialog, which allows you to create a new file.

Open ...

Shows the Open File Dialog, which allows you to open a specified file.

Save

Saves a file using its current name.

If the file in question is a newly created file, then the Save File Dialog is brought up to allow a name to be
entered.

This option is only enabled if your copy of dx.factory is registered.

Save As ...

Saves the selected file after a name has been entered in the Save File Dialog.

This option is only enabled if your copy of dx.factory is registered.

Save All

Saves all files that have been modified using their current names.

This option is only enabled if your copy of dx.factory is registered.

Open Workspace ...

This option allows you to select a previously saved Workspace, which is a Collection of open windows, and
the size and positions within the main dx.factory window.

When you select this option, a dialog opens which allows you to select an dx.factory workspace file (EXW).

Save Workspace ...

This option allows you to save the current size and position of the main dx.factory window, and the
arrangement of the open windows within dx.factory to a Workspace file.

This option is only enabled if your copy of dx.factory is registered.

Export to

This option brings up the following sub menu:
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These options allow you to Export the data in the currently selected file to a variety of different formats.

This option is only enabled if your copy of dx.factory is registered.

Exit

Exits the dx.factory application.

If any files have been modified and have not been saved, you will be given the option of saving them.
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The Edit Menu

The Edit menu provides the following options:

Undo

Undos the previous edit stored in the Undo Buffer.

Redo

Redos the next edit stored in the Undo Buffer.

Clear Undo Buffer

Clears the Undo Buffer.

Cut

Places a copy of the selected Object(s) onto the Clipboard and deletes the selected Object(s) from the file.

Copy

Places a copy of the selected Object(s) onto the Clipboard.

Paste

Copys the Object(s) on the Clipboard into the highlighted location within the current file.

Find ...

dx.factory supports the ability to find Objects either by name or by category (where an Object supports
categories, such as Voices).

Searches start from the currently selected Object.

Selecting the Find ... option brings up the Find dialog, that allows you to specify the string to search for, along
with options that can be used to refine the search.

Find Next

If you have defined the Find criteria within the Finddialog, then this option will repeat the search using the
same criteria.

Goto ...

Selecting this option brings up the Goto Dialog, which allows you to quickly navigate to a numbered Object.
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The View Menu

The View menu provides the following options:

Note how some of the options change depending on whether or not the Child Window is split.

When the Child Window is split the Left/Top Pane and Right/Bottom Pane menu options have the following
sub menu.

Tool Bar

When checked the dx.factory Tool Bar is visible.

Status Bar

When checked the dx.factory Status Bar is visible.

No Split

When checked the current Child Window is not split.

Horizontal Split

When checked the current Child Window is split horizontally.

Vertical Split

When checked the current Child Window is split vertically.

Tree

When checked the main/left/top pane in a Child Window displays data in a Tree View.

Table

When checked the main/right/bottom pane in a Child Window displays data in a Table View.

Refresh

Refreshes all open Child Windows.

This command is provided in case the screen is not properly updated following an edit operation. There are a
couple of odd bugs I cannot track down on screen updates. So if you come across them as well, then this
command will force a redraw of the windows.

Preferences ...

Opens the dx.factory Preferences Dialog.
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The MIDI Menu

Note: The MIDI option is only visible if you have registered dx.factory and enabled MIDI support in the MIDI
Preferences Tab in the Preferences Dialog.

The MIDI menu provides the following options:

Import From MIDI

Imports Voices and Performances from the DX via MIDI to the currently selected Window.

Export to MIDI

Exports Voices and Performances to the DX via MIDI from the currently selected Window.

MIDI Preferences ...

Opens the Preferences Dialog with the MIDI Preferences Tab active.
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The Window Menu

The Window menu provides the following options:

In the example given above, you'll see that after the predefined menu options there are menu options that
allow you to select the windows currently open within dx.factory (Analog3.SYX and BASELINE in our example
menu).

Tile Horizontal

Arranges all non−minimised Child Windows along the horizontal axis.

Tile Vertical

Arranges all non−minimised Child Windows along the vertical axis.

Maximise Windows

Maximises all Child Windows so they all occupy the size defined by the desktop.

Restore Windows

Restores all maximised/minimised Child Windows to their normal state.

Minimise Windows

Reduces all Child Windows to their iconised state.

View DX Synthesizer Data

Opens or closes the DX Synthesizer Window which provides a view on preset and user DX synth data.

This option is only available if dx.factory has been registered and MIDI Support is enabled.
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The Help Menu

The Help menu provides the following options:

Help ...

Displays the dx.factory Online Help system.

Tips and Tricks ...

Displays the dx.factory Tips and Tricks Dialog.

About ...

Displays the dx.factory About Dialog, which provides some basic information about the program, such as the
version number.

Register ...

Displays the dx.factory registration Dialog.

See the Registration Section for details of how to register dx.factory.
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Tool Bar
The Tool Bar contains buttons for common operations, such as opening and saving files.

  Displays the  New File Dialog to allow you to select the type of file to create
  Displays the  Open File Dialog to allow you to select a file to open
Saves the currently selected file
  Displays the Save As Dialog to allow you to select a different name for the currently selected file
Saves all the open files to disk
  Cuts the selected Objects and places them on the Clipboard
  Copies the selected Objects and places them on the Clipboard
  Pastes the contents of the Clipboard to the current selection
Undos the previous edit
Redos the previous edit
  Displays the Find Dialog to allow you to define the search criteria and then search for the first occurence
  Searches for the next occurence of the search criteria defined in the Find Dialog
  Imports Voices/Performances from the DX via the MIDI interface
  Exports Voices/Performances to the DX via the MIDI interface
  Displays the Preferences dialog where you can configure dx.factory
  Displays the dx.factory Online Help index page
  Enables Context Sensitive Help
  Displays the Tips and Tricks Dialog
  Displays the About Dialog

The Save and Midi Export buttons are only enabled if dx.factory is Registered.

The Tool Bar can be dragged and made a floating toolbar by clicking and dragging the handle to the left of the
Tool Bar.

The Tool Bar can also be dragged to a different window border other than the top border.

The Tool Bar can be hidden/unhidden by the Tool Bar menu option on the View menu.

The Tool Bar whilst floating can be docked once more by closing it.
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Desktop
The Desktop portion of the window is where the DX data is portrayed. Several files may be opened and
shown within Child Windows upon the Desktop portion of the window. The following example shows
three Child Windows open on the Desktop.

The Window Menu provides menu options to:

Tile (either vertically or horizontally) all Child Windows that are not iconised• 
Minimise all Child Windows• 
Maximise all Child Windows• 
Restore all Child Windows• 
Select a specific Child Window• 
Open the DX Synthesizer Window• 

When a file is opened, a Child Window is added to the Desktop Area.
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Child Window
The Child Window provides the View upon the data within the file it is associated with.

The Child Window is maximised by default when it is opened, and can be minimised, restored or closed by the
buttons to the right of the Child Window's title bar.

The menu options on the View menu can be used to change the View to a Table view, which can show either
a Voice Table in S1V, S1A or S1Y files and/or a Performance table in S1A and S1Y files.

It's also possible to have either a horizontally or a vertically split View which can show any of the following
combinations:

A Tree and a Table• 
A Table and a Tree• 
Two Trees• 
Two Tables• 

The default Child Window View applied when a file is opened is set in the Default View Tab of the Preferences
Dialog.

The following example shows a Child Window that is split and showing both a Tree View and a Table View on
the same data.

The Tree and Table views support drag move and drag copy operations, and the views will automatically
scroll whilst drag operations are in progress.

dx.factory also provides a special Child Window called the DX Synthesizer Window.
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Tree View

The Tree View shows the DX data as a hierarchical tree, and can show more information than the Table
View. The following example shows a split Child Window with two Tree Views, one collapsed showing the top
level Collections and one showing a Performance (01) that has been expanded to show more information
on the Performance.

Basically, information is shown as a set of hierarchical Objects. Objects may have children attached to them,
and they themselves may have further child Objects (e.g. a Voice Object, has a child Object for its Operators,
and this Object groups all the Operators of the Voice).

The basic tree structure is a Root Object at the top of the tree under which are various Object Collections
which themselves contain further data. The top level Collections that can be found under the root node varies
upon the file type:

SYSEX File − this is the root of the data currently loaded and a container for all data held in the DX
Synthesizer data file which has been loaded. This root is always present.

• 

User Voices − The Voices from an DX SYSEX data file• 
User Performances − The Performances from an DX SYSEX data file• 

Objects are displayed in one of two colours:

Black if the Object is not referenced by another Object• 
Blue if an Object is referenced by another Object (e.g. a Voice being used within a Performance, or a
Sample being used by a Wave)

• 

The Tree View allows multiple Objects to be selected, which is useful for performing operations only upon
certain Objects. You can only perform operations upon Objects of the same type.

If you wish to perform an operation upon all Objects in a Collection, simply select the Collection containing the
Objects.

The dx.factory Window 19



Table View

The Table View provides a more high level overview of the data than the Tree View, and the representation of
the data is more compact. The following example shows a Child Window with a single Table View providing
information on a file's Voices.

The Table View can only show one Collection of Objects at a time.

Currently the Table View can show Voices in SYSEX files or Performances in SYSEX files.

You can select whether a Table View shows Voices or Performances by right clicking within the table to
access the context sensitive menu, upon which can be found menu options to select either a Voice Table or a
Performance Table.

Each row within the table shows one Object.

The Table View's context sensitive popup menus support editing operations. The cell in a Row that contain
the Object Name can be directly edited by clicking in it.
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DX Synthesizer Window

The DX Synthesizer Data Window is made visible by ensuring the View DX Synthesizer Data option in
the Window Menu is checked.

This Child Window is a special View that shows the following DX User Data Collections:

User Voices• 
User Performances• 

The purpose of showing these User Data Collections is to allow drag and drop transfers of User Voices
and User Performances between dx.factory and the DX via the MIDI Interface.
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Status Bar

The Status Bar provides the following pieces of information (from left to right) for the Child Window which is
currently selected:

The name of the file currently open, if any. If no file has been selected then this field is blank• 
The type of the file• 
Whether or not the file has been modified• 
If the left/top split pane is a table this indicator identifies what the table is showing (Voices or
Performances)

• 

If the right/bottom split pane is a table this indicator identifies what the table is showing (Voices or
Performances)

• 

The Status Bar can be hidden/unhidden by the Status Bar menu option on the View menu
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Program Features
dx.factory provides the following features:

File Operarations• 
Undo/Redo Support• 
Clipboard Support• 
MIDI Support• 
Find and Goto Support• 
Editing Features• 
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File Operations
dx.factory supports the following file operations:

Create New Files• 
Open Existing Files• 
Save Files• 
Open and Save Workspaces• 
Export Data• 
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Create New File

When the New File ... option from the File Menu or the  button on the Toolbar is selected:

If the Device Type Setting in the Device Type Tab in the Preferences Dialog is set to DX7 then a
new file that contains 32 Voices is created

• 

If the Device Type Setting in the Device Type Tab in the Preferences Dialog is set to DX7II then the
following dialog is shown:

• 

This dialog allows you to select what banks are created in the file from the following:

Voice Bank A• 
Voice Bank B • 
Performance Bank• 

The initial values for these settings are setup in the New File Default Preferences Tab in the Preferences
Dialog.

The new data file is given a name in the form of "dxfactory_n", where n is a number that increments every
time a file is created.

Note, this is different from initialising data in a file, as a totally new file is created.
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Open Existing File

When the Open ... option from the File menu or the  button on the Toolbar is selected, the following dialog
will appear allowing a file to be selected.

dx.factory checks to ensure that the selected file is a valid Yamaha format file, and an error dialog will appear
if the file is not valid.

If a file selected for opening is already open, dx.factory will ask if you want to replace the file that is in
memory.

Program Features 26



Save Open Files

When you save a file to disk using: the Save As ... command from the File Menu, or when a file created using
the New ... command from the File Menu is saved for the first time, the following dialog appears to allow you
to select a name for the file
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Workspaces

dx.factory allows you to save the current size and position of the main dx.factory window, and the
arrangement of the open Child Windows within dx.factory to a file known as a Workspace.

This allows you to save a Workspace you are using for future recall at a later date.

The following for each Child Window remembered:

Window size, position and status (normal, maximised or minimised)• 
Horizontal/Vertical Splits, including split position• 
Pane type(s) (e.g. Tree, Voice Table or Performance Table)• 
Tree node expansion status• 
Table column widths• 
Scroll position of the pane(s)• 
Selection state of the tree nodes, or table rows• 
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Export Data

dx.factory allows you to export the data in the currently selected file to a variety of different formats.

HTML• 
XML• 
Cubase VST Patch List• 
ProTools Patch List• 
Sonar Patch List• 
SpreadSheetML• 

HTML ...

This option allows you to export a listing of the data in HTML format.

If the file being printed contains several banks, the following dialog will appear allowing you to select the
features to be exported:

XML ...

This option allows you to export a listing of the data in XML format.

If the file being printed contains several banks, the following dialog will appear allowing you to select the
features to be exported.

This export option is intended to provide a means of importing DX data into other programmes, e.g. a
database

Cubase VST Patch Script ...

This option allows you to export a listing of the Voice/Performance data in Cubase VST patch script format.

This allows you to create patch scripts for use within Cubase to ease the selection of patches within the
Cubase environment.

Consult your sequencer documentation for details on how to install the patch scripts within your sequencer.

Protools Patch Script ...

This option allows you to export a listing of the Voice/Performance data in Protools patch script format
(MIDMAN files).

This allows you to create patch scripts for use within Protools to ease the selection of patches within the
Protools environment.

Consult your sequencer documentation for details on how to install the patch scripts within your sequencer.

Sonar Patch Script ...

This option allows you to export a listing of the Voice/Performance data in Sonar patch script format.

This allows you to create patch scripts for use within Sonar to ease the selection of patches within the Sonar
environment.
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Consult your sequencer documentation for details on how to install the patch scripts within your sequencer.

SpreadSheetML ...

This option allows you to export a listing of the data in Microsoft SpreadSheetML format.

The following dialog will appear, allowing you to select the features to be exported.

This export option is intended to provide a means of importing DX7 data into either Microsoft Word or Excel,
which is a great way to start documenting your patch collections.
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Undo Buffer
dx.factory supports a multi−level Undo/Redo Buffer facility on all edits.

The number of edits which are stored is 100.

The Undo/Redo commands can be found both within the Edit Menu, and on the Toolbar.

Please note that the undo buffer is global across all open files, and is cleared when any file is closed. This
may be improved in later releases.

The undo buffer can be cleared by the selecting the Clear Undo Buffer option on the Edit Menu. The
intention of this feature is to help cope with low memory situations, as it will free up the memory used by
stored edits.
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Clipboard Support
The dx.factory clipboard works just like the clipboard in other applications. It allows you to place an Object or
a copy of an Object upon the clipboard and then paste that Object elsewhere within a file or another file.

You can Cut/Copy either a single Object or a Collection of Objects onto the clipboard.

You can only paste from the clipboard to the current location in a file if it makes sense to do so. For example:

You cannot paste a Voice onto a Performance• 
You cannot paste ten Voices at the end of a Voice Collection if the selection is at Voice 56 or higher• 

The dx.factory clipboard is "local" to the application, and only dx.factory Objects can be placed upon it.

dx.factory does not support the system clipboard so it is not possible to cut and paste between dx.factory and
other applications. I don't think this is a major drawback because I cannot think of any circumstances where
you would wish to do this!
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MIDI Support
To use dx.factory MIDI Export support, your copy of dx.factory needs to be registered.

Configuring MIDI Support

To configure MIDI support, go to the MIDI Preferences tab in the Preferences Dialog, and set up the following:

Input MIDI Port and Output Midi Port should be set to the MIDI port(s) to which the DX is connected• 
SYSEX Device Number should match the DX7 Device Number setting • 

If the Device Number on the DX is set to ALL then it will accept data for any SYSEX Device.

You can check that these settings work by pressing the Test DX MIDI Settings button. When you press this
button a test message is sent to the DX and the subsequent Dialog will tell you if communication was
successful or if there was a problem.

The above steps set up the basic communication mechanism for MIDI support, and you then can set up the
remaining options according to your preferences:

If you never work with Performances then you can exclude them from the bulk transfers by clearing
the Include Performances in Bulk Transfer checkbox

• 

If you wish for dx.factory to always read the DX Voice/Performances on startup then check the Read
DX MIDI Data on Startup checkbox

• 

If you wish for changes made to the DX Synthesizer Window to be automatically written to the DX
then check the Automatically Update DX after Synth Window Edit checkbox

• 

The Transmit Buffer Size, Transmit Delay Between Buffers and Transmit Delay Between Objects values
should not require adjustment. dx.factory sends data to the DX7 by dividing the data into packets the size of
which are specified by the Transmit Buffer Size value. When dx.factory sends a packet it waits for the time
period specified by Transmit Delay Between Buffers before sending the next packet, and it waits for the
time period specified by Transmit Delay Between Objects after the last packet is sent. The delay
parameters are specified in milliseconds. You may need to adjust these values (smaller buffers, longer
delays) if communications is not reliable, and you may if you wish adjust these values (larger buffers, smaller
delays) to maximise data transfer performance. If you adjust these values, please ensure that you test the
transfer to ensure it is reliable, otherwise you may risk losing data. Note: Some MIDI interfaces do not like
large packet sizes: I recently upgraded to a MOTU interface and ran into problems with MIDI export until I
altered dx.factory to send messages in small chunks defined by the above parameters!

Copying/Moving Voices and Performances

In operation, using MIDI is quite straightforward.

You can get all the DX Voices/Performances into any Child Window (including the DX Synthesizer
Window) by selecting the Import from MIDI option on the MIDI Menu, or the    button on the Tool Bar.

This imports all Voices, and all Performances if you have set the MIDI Preferences options to include
Performances during the bulk transfers.

Similarily you can also export all Voices and Performances using the Export MIDI option on the MIDI Menu,
or the    button on the Tool Bar.

Note if you import or export MIDI data to/from a Child Window which is opened from a data file, then the DX
Synthesizer Window is also updated with the Voices/Performances being imported/exported.

And you can also move/copy Voices/Performances between the DX Synthesizer Window and Child Window
using drag and drop.

You can also import/export a Voice or Performance to/from the DX Edit Buffer by selecting a single
Voice/Performance and selecting the import/export to/from DX Edit Buffer options from the Voice's or
Performance's Context Sensitive Menu. You can also use the keyboard shortcuts for doing this

Exporting Voices from dx.factory to the DX Edit Buffer is really handy, for example, when trying to find a
particular Voice in a file and you don't wish to load it into the DX.

Finally you can also perform all the operations on Voices/Performances in the DX Synthesizer Window that
you can upon Voices/Performances in a normal Child Window.

If you have the Automatically Update DX after Synth Window Edit option active, when you change data
the DX Synthesizer Window then the changes are automatically exported to the DX. 
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So you may wish to turn the Automatically Update DX after Synth Window Edit option off during intensive
editing sessions. Once you've made all your changes you then select the Export MIDI option on the MIDI
Menu, or the    button on the Tool Bar  Export option to manually export the changes.

If you quit dx.factory with changes still present in the DX Synthesizer Window that have not been exported,
then you will be asked if you wish to export the data or not.
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Find and Goto Facilities
Find Dialog

dx.factory supports the ability to find Objects by name.

Searches start from the currently selected Object.

Selecting the Find ... option on the Edit Menu brings up the Find dialog, that allows you to specify the string to
search for. In addition there are several options that can be selected

Find What The text string to search for.
Match Case If this option is checked then the search is case sensitive. If this option is not

checked then the search is case insensitive.
Match Whole
Name

If this option is checked then the search string must match the entire name of an
Object. E.g. "pan" would match a Voice called "pan", but not a Voice called
"pandora". If this option is not checked then the search can match a sub string
within a name. E.g. "dor" would match a Voice named "dor" and a Voice called
"pandora".

Use Wild Cards If checked dx.factory will treat the "Find What" text as a "regular expression" to
allow you more control over the search, such as matching text at the start of a
name, or the end of a name, words with numbers in, etc.

The regular expression language used for dx.factory wild card support is the Perl Regular Expression Syntax.
Rather than try and write up this powerful syntax myself into the dx.factory documents, I'll direct you to
the Perl Regular Expression Syntax page for a description of how to use this powerful feature.

Goto Dialog

Selecting this option on the on the Edit Menu brings up the Goto Dialog

Item Type The type of Object to go to

The types of Objects that can be selected depends upon the type of file• 
If a Voice Table is the selected view, then you can only Goto another Voice• 
If a Performance Table is the selected view, then you can only Goto another
Performance

• 

Item Number The number of the Object to go to.
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Editing Features
dx.factory supports the following editing features:

General Editing Features• 
Synth Editing Features• 
Voice Editing Features• 
Performance Editing Features• 
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General Editing Features

dx.factory supports many editing features, some of which are classed as general features that are applicable
to all or most Objects.

The general features are described here in one place for convenience:

Copy/Move Object• 
Initialise Object• 
Rename Object• 
Insert Object• 
Delete Object• 
List Object References• 
Sort Objects• 

The following table shows whether or not a general edit operation can be applied to a particular type of
Object:

Object Type Move Copy Initialise Rename Insert Delete List Sort
Synth Object Y Y Y N N N N N
Voice Collection Y Y Y N N N N Y
Voice Y Y Y Y Y Y Y N
Voice Operator Collection Y Y Y N N N N N
Voice Operator Y Y Y N Y Y N N
Performance Collection Y Y Y N N N N Y
Performance Y Y Y Y Y Y N N
Performance Part N N Y N N N N N
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Copy/Move Object

dx.factory makes extensive use of drag and drop for copying and moving Objects.

You can drag copy or move Objects within a file or between files, and you can drag single items or multiple
items.

The default drag operation is to move an Object, and there are two types of move operations:

Moving an Object within its Parent Collection (e.g. moving a Voice from location 1 to location 4)• 
Moving an Object to a new Parent Collection (e.g. moving a Voice from one file to another file)• 

When you move an Object to a new Parent Collection then the original Object is removed and replaced with
an initialised Object of the same type. 

To copy an Object using drag and drop, you must have the DRAG MODIFIER key held down during the
operation. The DRAG MODIFIER key is platform dependent. On the PC platform it is the CTRL key.

You can tell that a copy operation is in progress as the drag image icon has a + sign visible. 

When you drag multiple items they must be of the same type. For example you can drag several Voices, but
not Voices and Performances together.

dx.factory provides the following drag/drop feedback to assist in determining the effects of a drag/drop
operation:

Cursor: Indicates if the move is either a copy or a move, or if the drop is invalid (e.g. trying to drag a
Voice onto an Element)

• 

Drag image: A simple pictorial representation of what is being dragged• 
Drop Point: dx.factory shows the drop point as either a cue line drawn between Objects if an Object is
being moved within its parent (e.g. an Operator within a Voice), or a cue rectangle drawn around the
drop location for all other moves and copy operations which are valid

• 

When a Child Window is split, Objects can be dragged and dropped between either side of the split point.
This is handy, for example, for dragging Objects between the start of a Collection and the end of a Collection.

The Tree and Table views will auto−scroll in drag and drop operations, when you move the cursor to either
the top or the bottom of the pane and hold it there.

If you drag an Object onto a Tree View and over a valid parent Object (e.g. an Operator over a Voice) and the
parent Object is collapsed within the Tree, and you hold the cursor over the Parent Object for a few seconds it
will automatically expand.

dx.factory will maintain the references to Voices in Performance Parts when moving Voices within a file. 

For example if you move a Voice from Location 2 to Location 10, then any Performance Parts which are
referencing Voices at Locations 2 and above will be updated to ensure they still reference the same Voices
after the move operation as they were before the move operation.

The ability to update Voice references following a move or to copy referenced Voices during a move to a new
file can be selectively turned on or off within the Preferences Dialog.

Initialise Object

Initialises the selected Object to its default state.

Multiple Objects of the same type can be selected for initialisation.

The Initialise command is found upon the Context Sensitive Menu in both the Tree View and the Table
View.

Rename Object

Renames the selected Object using the following dialog:

Program Features 38



Only one Object can be selected for renaming.

The Rename command is found upon the Context Sensitive Menu in the Tree View

To rename Objects in the Table View , simply double click in the Name Cell of the required Object to edit the
name.

Insert Object

Inserts an Object into a Collection at the current location.

The Insert command is found upon the Context Sensitive Menu in both the Tree View and the Table View.

You can insert more than one Object at a time by selecting multiple Objects prior to executing the Insert
command.

For example if you wish to insert three Performances at location 10, select Performances 10, 11 and 12 and
then execute the Insert command.

Note that when you insert one or more Objects, then the commensurate number of Objects at the end of the
Parent Collection are removed if required. This is necessary to maintain the correct number of Objects in a
Collection.

For example, a DX7 Voice Collection can only contain 32 Voices, so if two Voices are inserted into the
Collection then two Voices must be removed from the end of the Collection to maintain the correct size.

dx.factory will maintain the Performance Part references to Voices when inserting Voices. 

For example if you insert a Voice into a file at Location 10, then any Performance Parts which are
referencing Voices at Locations 10 and above will be updated to ensure they still reference the same Voices
after the insert operation as they were before the insert operation.

Delete Object

Deletes an Object at the current location.

The Delete command is found upon the Context Sensitive Menu in both the Tree View and the Table View.

You can delete more than one Object at a time by selecting multiple Objects prior to executing the Delete
command.

For example if you wish to delete three Performances at location 10, select Performances 10, 11 and 12 and
then execute the Delete command.

Note that when you delete one or more Objects, then a commensurate number of Objects at the end of the
Parent Collection are added if required. This is necessary to maintain the correct number of Objects in a
Collection.

For example, a DX7 Voice Collection must contain 32 Voices, so if two Voices are deleted from the Collection
then two Voices must be added to the end of the Collection to maintain the correct size.

dx.factory will maintain Performance Part references to Voices in a Collection when deleting Voices. 

For example if you delete a Voice from a SYSEX file at Location 10, then any Performance Parts which are
referencing Voices at Locations 10 and above will be updated to ensure they still reference the same Voices
after the delete operation as they were before the delete operation.

List Object References

The List References command is found upon the Context Sensitive Menu in both the Tree View and
the Table View.

The List References command is only available if:

Only one Voice is selected• 
The Voice selected is referenced by a Performance, which is indicated by the Voice being coloured
blue

• 

The references are shown as follows:
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The Voice being referenced is shown at the top of the Dialog followed by the Performances referencing it.

Sort Objects

The Sort by Name command is found upon the Context Sensitive Menu in both the Tree View and
the Table View.

In the Tree View the sort options are accessed via the Context Sensitive Menu for the Collection that you
wish to sort (e.g. the Voice Collection to sort Voices).

In the Table View the sort options are accessed via the Context Sensitive Menu for any Object. The sort can
also be initiated by clicking in the Namecolumn header.
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Synth Editing Features

dx.factory supports the following editing operations upon the Synth Object within the Tree View of a Child
Window:

Move• 
Copy• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access these features, right click over the Synth Object to activate the Synth Object's Context Sensitive
Menu.

The Synth Object is only shown within a Tree View and is the first Object in the Tree View. It is called:

SYSEX File
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Voice Editing Features

dx.factory supports the following editing operations upon the Voice Collection shown within the Tree View of
a Child Window:

Copy/Move• 
Initialise• 
Sort by Name• 
Import Data From DX7• 
Export Data to DX7 (only available if dx.factory is registered) • 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

The Voice Collection Object in file is only shown within a Tree View and is called User Voices.

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Voice Collection to activate the Voice Collection's Context Sensitive Menu.

dx.factory supports the following editing operations upon the Voice Objects within the Tree View or Table
View of a Child Window:

Copy/Move• 
Initialise• 
Rename• 
Insert• 
Delete• 
List References• 
Import from DX7 Edit Buffer• 
Export to DX7 Edit Buffer (only if available dx.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Voice
or selection of Voices to activate the Voice's Context Sensitive Menu.

You can also directly edit the Voice Operators

Import from DX Memory

Imports Voices from the DX Memory locations into the currently selected Child Window.

Export to DX Memory

Exports Voices from the currently selected Child Window to the DX Memory locations.

Import from DX Edit Buffer

Imports the Voice currently in the DX Edit Buffer (i.e. the currently selected Voice on the DX) into the Voice
currently selected within the active Child Window.

Note if you have more than one Voice selected then this operation is not available

Export to DX Edit Buffer

Exports the Voice currently selected within the active Child Window to the DX Edit Buffer.

Note if you have more than one Voice selected then this operation is not available

Voice Operator Editing Features

dx.factory supports the following editing operations upon the Voice Operator Collection shown within
the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over
the Voice Operator Collection to activate the Voice Operator Collection's Context Sensitive Menu.
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dx.factory supports the following editing operations upon the Voice Operator Objects within the Tree View of
a Child Window:

Copy/Move• 
Initialise• 
Insert• 
Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a
Voice Operator or selection of Voices Operators to activate the Voice Operator's Context Sensitive Menu.
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Performance Editing Features

dx.factory supports the following editing operations upon the Performance Collection shown within the Tree
View of a Child Window:

Copy/Move• 
Initialise• 
Sort by Name• 
Import Data from DX7• 
Export Data to DX7 (only available if dx.factory is registered) • 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

The Performance Collection Object in a file is only shown within a Tree View and is called User
Performances.

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Performance Collection to activate the Performance Collection's Context Sensitive Menu.

dx.factory supports the following editing operations upon the Performance Objects within the Tree View
or Table View of a Child Window:

Copy/Move• 
Initialise• 
Rename• 
Insert• 
Delete• 
Import from DX7 Edit Buffer• 
Export to DX7 Edit Buffer (only if available dx.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a
Performance or selection of Performance to activate the Performance's Context Sensitive Menu.

You can also directly edit the Performance Parts  that make up a Performance:

Import from DX Memory

Imports Performances from the DX Memory locations into the currently selected Child Window.

Export to DX Memory

Exports Performances from the currently selected Child Window to the DX Memory locations.

Import from DX Edit Buffer

Imports the Performance currently in the DX Edit Buffer (i.e. the currently selected Performance on the DX) to
the Performance currently selected within the active Child Window.

Note if you have more than one Performance selected then this operation is not available

Export to DX Edit Buffer

Exports the Performance currently selected within the active Child Window to the DX Edit Buffer.

Note if you have more than one Performance selected then this operation is not available

Performance Part Editing Features

dx.factory supports the following editing operations upon the Performance Part Objects within the Tree
View of a Child Window:

Set Voice• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Set (which you do via "Drag and Drop"), right click over a Performance
Part or selection of Performance Parts to activate the Performance Part 's Context Sensitive Menu.

Set Voice
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If Voices are present in the current file, then a User Voice from the same file can be dragged onto a
Performance Part to set the Voice used by the Performance Part.

Please note, the drag operation for this is COPY only. You cannot MOVE a Voice onto a Performance Part.
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Master Patch List

The Master Patch List Dialog is found on the Tools menu.

This feature is only available if your copy of dx.factory is registered.

The Master Patch List Dialog provides a means for you to generate a single patch list from a list of files.
Currently only Cubase Patch Scripts can be generated, but future versions may support other sequencers.

The Master Patch List dialog is shown below:

This dialog has the following options:

File List The list of files to incorporate into a single patch list.

If you click on one of the lines then you can edit the file either by
typing or by using the [...] button to the right of the line to bring up a
file selector dialog.

Note, if you are editing a line, and you are finished, you need to
select another line, or press the RETURN key for the changes to be
stored.

New Inserts a new line in the file list.
Delete Deletes the currently selected line in the file list. If no line is

selected this control is disabled.
Move Up Moves the currently selected line in the file list up one line. If no line

is selected or the selected line is the first in the list then this control
is disabled.

Move Down Moves the currently selected line in the file list down one line. If no
line is selected or the selected line is the last in the list then this
control is disabled.

Sort Sorts the lines into ascending alphabetical order
Cubase Exports the files identified in the file list to a Cubase format patch

script file, which is compatible with Cubase VST/SX/SL/SE.
OK Closes the dialog.

Generating The Cubase Master Patch List

When you generate a Cubase Patch Script, it is written to the directory specified by the Cubase Patch Script
Directory field in the Misc Preferences Tab of the Preferences Dialog. You can set this field up to export the
master patch list directly to the directory read by Cubase upon startup. This directory on my system is
C:\Documents and Settings\Derek\Application Data\Steinberg\Cubase SX
3\Scripts\Patchnames\inactive\yamaha where "C:" is the root drive that Cubase is installed on, "Derek" is
my Windows user name, aand "Cubase SX 3" is my version of Cubase. You will need to vary these
according to your system drive and of course your own user name and version of Cubase.
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By default the Application Data folder is hidden in Windows Explorer, so you may not see this folder first of
all. If you cannot see the folder:

In Windows Explorer select Folder Options from the Tools menu and click the View tab.1. 
Look down the Advanced Settings list and find the Hidden Files and Folders option.2. 
Select the Show Hidden Files and Folders sub option.3. 
Select OK to close the dialog.4. 

Cubase only looks for and reads patch scripts when it starts up, so if you're in Cubase after generating the
patch script then exit Cubase and start it up again.

Configuring Cubase to Use the Master Patch List

The patch scipts generated by dx.factory should be compatible with Cubase VST/SX/SL/SE. The instructions
given below are for Cubase SX, which is the version I use. Consult your Cubase documentation for how to
install patch scripts if you have a different version.

Within Cubase:

Select Midi Device Manager from the Devices Menu.1. 
Click on the Install Device button.2. 
Click on the DX7 − Master Patch List option (this is the dx.factory generated file). At the bottom of
this dialog, select your output MIDI port that the DX7 is connected to. You can now close this dialog. If
you cannot see the DX7 − Master Patch List then you have not placed it in the right folder.

3. 

This installs the patch list within Cubase and allows you to use it elsewhere within the application.

In the main Cubase screen, select or create a MIDI track that you wish to be used with the DX7. In the
Inspector window (the panel to the left of the main window) click on the out control and you should now be
able to see and select the DX7 − Master Patch List option in amongst the MIDI ports. Also ensure the MIDI
channel number for the track matches the DX7 channel number.

Now when you click in the Programs control, just below the out control, you'll see a drop down list containing
all of the DX7 Voices names generated by dx.factory.

You can now scroll through the lists to find a Voice, an you can also type in filter text to quickly look for a
Voice.
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Preferences
The dx.factory preferences are accessed via the View menu Preferences ... option.

Selecting this option opens a Tabbed dialog with the following tabs which group related parameters:

Device Type Preferences• 
New File Default Preferences• 
Performance Preferences• 
Check Preferences• 
Default View Preferences• 
MIDI Preferences• 
Miscellaneous Preferences• 

To view and modify a set of parameters, click on the relevant tab.

Note: The options to update Performances following a Voice move within the same file also apply when
Voices are inserted, deleted and sorted. 

Note: The options to copy referenced Voices with "parent" Performances work by:

Checking the destination file to see if the referenced Voice exists• 
If it does then the parent Performance is updated after being moved to point to the existing Voice in
the destination file

• 

If not then dx.factory checks to see if a blank or empty Voice is present in the destination file • 
If a blank Voice is found then the child Voice is moved or copied and the parent Voice is updated after
being moved to point to the new Voice in the destination file

• 

If no blank Voice is found the dx.factory gives up. Note this may result in a Partial edit (e.g. it may
have only been possible to copy a subset of Performances due to the amount of free Voices in the
destination file)

• 

The Voices are only ever copied irrespective of whether the parent Performance is being moved or
copied. This is to avoid the problem that would occur when a Voice is moved, where the source Voice
(which would have been initialised after the move) is also referenced by other Performances

• 
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Device Type Preferences
The Device Type Preferences tab is shown below:

This tab has the following options:

DX Device Type Allows you to select the type of DX you have from the following
options:

DX7• 
DX7 II• 

If this parameter is set to DX7 then new SYSEX files are created
that can hold 32 Voices.

If this parameter is set to DX7II then new SYSEX files are created
according to the settings in the New File Default Preferences Tab.
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New File Default Preferences
The New File Default Preferences tab is shown below:

This tab is only enabled if the Device Type is set to DX7II

This tab has the following options:

Voice Bank A (01−32) When checked the Voice Bank A checkbox in the New File Dialog
will be initially checked when the Dialog is opened.

Voice Bank B (32−64) When checked the Voice Bank B checkbox in the New File Dialog
will be initially checked when the Dialog is opened.

Performance Bank When checked the Performance Bank checkbox in the New File
Dialog will be initially checked when the Dialog is opened.
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Performance Preferences
The Performance Preferences tab is shown below:

This tab is only enabled if the Device Type is set to DX7II

The options in this tab are only effective in files for a DX7II that have both Voice and Performance banks

This tab has the following options:

Update Performances/Parts After
Voice Move

If you move a Voice within an SYSEX file then the Performances
and their Parts are updated to ensure that the correct references to
User Voices are maintained.

Copy User Voices With Performance If you move or copy a Performance from an SYSEX file to another
SYSEX file, then any User Voices referenced by the Performance
and its Parts are also copied to the destination file if the Voices are
not already present in the destination file.

Start Voice Copy With Performances
In Voice Bank B

If this option is selected then when Voices are copied to a new file
along with Performances the Voices are copied into bank B only.
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Check Preferences
The Check Preferences tab is shown below:

This tab has the following options:

Check For Duplicates When Moving
or Copying Objects

If you move or copy an Object to a destination file and the Object
already exists then a warning is presented giving you the option to
continue or cancel the operation.

Warn if Destination Object is
Referenced When Moving or Copying
Objects

If you move or copy an Object and it is overwriting an Object that is
being referenced, or you are deleting a referenced Object, then a
warning is presented giving you the option to continue or cancel the
operation.
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Default View Preferences
The Default View Preferences tab is shown below:

Default View Defines the type of view that is applied to a Child Window when it is
first opened.

The following options are available:

No Split• 
Horizontal Split• 
Vertical Split• 

Pane/Left Pane/Top Pane Defines the type of view shown in the single pane of an unsplit
view, the left pane of a horizontally split view or the top pane of a
vertically split view.

The following options are available:

Tree View• 
Table View• 

Right Pane/Bottom Pane This control is only visible if the Default View option is set to either
Horizontal Split or Vertical Split.

Defines the type of view shown in the right pane of
a horizontally split view or the bottom pane of a vertically split view.

The following options are available:

Tree View• 
Table View• 

View Tool Bar Controls if the toolbar is visible at startup.
View Status Bar Controls if the status bar is visible at startup.
View Backdrop In Child Window This option controls if the image backdrop is displayed in Child

Windows.

You may wish to turn off this option if you find the scrolling of the
Child Window is slow on your machine.

Preferences 53



MIDI Preferences
The MIDI Preferences tab is shown below:

This tab has the following options:

Enable MIDI Support If checked then dx.factory MIDI support is enabled.
Input MIDI Port Sets the port used for MIDI input from the available ports.
Output MIDI Port Sets the port used for MIDI output from the available ports.
SYSDX Device Number Sets the SYSEX device number used for SYSEX transfers. This

must match the Device No value set in the DX's MIDI pages. If the
DX Device No is set to all then it will receive all DX SYSEX
messages irrespective of the device number in the message.

Timeout Delay Sets the time that dx.factory waits for a response from the DX7
before timing out and reporting an error. The value is specificied in
milliseconds.

Transmit Buffer Size Sets the size of the transmit buffer used for sending data to the
DX7. Some MIDI interfaces don't like data coming in big chunks
and you may need to set this to get a reliable transfer of data. The
value is specificied in milliseconds.

Transmit Delay Between Buffers This sets the delay that dx.factory waits for between sending buffer
sized data packets. The value is specificied in milliseconds.

Transmit Delay Between Objects This sets the delay that dx.factory waits for after sending a
complete object. The value is specificied in milliseconds.

Automatically Update DX after Synth
Window Edit

When this option is checked, if the DX Synthesizer Window is
edited then the edited data will be automatically sent to the DX.

Read DX MIDI Data On dx.factory
Startup

When this option is checked the Voices and Performances (if
enabled) are read from the DX during the dx.factory startup phase.

Automatically Turn Off DX7II Memory
Protection

If you have set the device type to DX7II then this option allows you
to automatically turn off the DX7II memory protection.

Include Performances In Bulk
Transfer

When this option is checked, the Performances are included in bulk
transfers. You may wish to uncheck this option if you don't use
Performances.

Test DX Midi Settings
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Tests to see if MIDI comms is working using the specified values.
The test:

Send a Voice Edit Buffer Request message on the
specified MIDI output port

1. 

Waits for a response on the specified MIDI input port. If the
response times out an error message is displayed

2. 

If the Device Type is set to DX7II the a Voice Edit Buffer
Supplemental Data Request message is sent to the DX

3. 

Waits for a response on the specified MIDI input port. If the
response times out an error message is displayed

4. 
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Miscellaneous Preferences
The Miscellaneous Preferences tab is shown below:

This tab has the following options:

Startup Directory Allows the startup directory to be specified. Note: no validation is
performed on this pathname, so please ensure it is valid. I may add
validation later.

Cubase Patch Script Directory

Specifies the directory where Cubase patch scripts are written.
Note: no validation is performed on this pathname, so please
ensure it is valid. I may add validation later.

The [...] button to the right of the field brings up a dialog that allows
you to select the directory instead of typing it in.

Load Last File On Startup Controls if the last file opened in the previous session is
automatically loaded when dx.factory is next invoked.
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Online Help
dx.factory provides a full online version of the dx.factory manual.

If you select Help ... from the Help Menu or the  button on the Tool Bar, the Help Window is opened.

The Help Window works just like a web browser window, so its operation should be quite familiar to you.

The left pane of the Help Window shows a tabbed navigation pane to allow you to quickly navigate to a topic,
whilst the right hand pane shows the help topic.

The navigation pane can show three different views, depending on which tab you select:

   Displays the Table of Contents Navigation Pane, providing a structured list of dx.factory topics• 
   Displays the Index Navigation Pane, providing an indexed list of dx.factory topics• 
   Displays the Search Navigation Pane, allowing you to search the help topics for keywords• 

The Help Window has the following Tool Bar buttons:

   Navigates backwards to the last page in the access sequence. If you press and hold the mouse
button over this button, you will get a list of accessed pages

• 

   Navigates forwards to the next page in the access sequence. If you press and hold the mouse
button over this button, you will get a list of accessed pages

• 

   Selects the home page• 
   Refreshes the current page• 
   Prints the current page• 
   Displays the print settings dialog• 
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Context Sensitive Help
You can access context sensitive help by:

pressing the your Computer Platform's Help Key (F1 on the PC platform), which will load the help
page associated with the Component within the dx.factory Window that currently has Focus (is
responding to the keyboard and mouse).

• 

pressing the  button on the Tool Bar and the clicking over the item of interest• 

You can press the Help Key in any dx.factory Dialog to access the relevant help page for the Dialog.
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Tips and Tricks
The dx.factory tips and tricks dialog is shown below:

This dialog has the following controls:

Close Closes the Tips and Tricks Dialog
Next Tip Selects the next tip in sequence
Show Tips at
Startup

If checked then when dx.factory starts up, the Tips and Tricks Dialog is automatically
opened

List of Tips and Tricks
Just in case you want the tips and tricks shown by the dialog as one single list, here they are.

MIDI Support

dx.factory supports the transfer of Voices and Performances between dx.factory and the DX7 via MIDI.

(NOTE: MIDI export features are available only to registered users).

Context Sensitive Help

If you press the Help Key (F1 on a PC) then you can get context sensitive help, including within Dialogs.

Keyboard Shortcuts

dx.factory supports numerous keyboard shortcuts as an alternative to using the mouse.

Take a look in the online help or the dx.factory manual for details of the supported keyboard shortcuts

Object Colouring

If a Voice is coloured blue, then it is being referenced by a Performance.

If you right click over a blue Voice you'll find a "List References" context menu item, which will show you the
Performances that reference this Voice.

Table Sorting

You can sort Voice and Performance Tables by name by clicking in the Table Name Column header.

You can only DRAG COPY Certain Objects

If you are trying to perform a drag operation of a Voice onto a Performance Part and are wondering why
dx.factory is not allowing you to perform the drag, you must be holding down the CTRL key during the drag.
Holding down the CTRL key turns the operation from a Drag Move operation to a Drag Copy operation.

Sometimes during a drag operation, the only sensible operaton that can be undertaken is a copy operation.
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Copying/Moving Performances to a Different File

When you copy an Performance to a different file then any Voices it references can also be copied at the
same time.

I think you'll agree this is a cool feature!

This feature can be off if required within the Preferences Dialog.

Master Patch List

The Master Patch List dialog under the Tools menu allows you to define a list of files that are exported, along
with preset voice definitions, as a master patch list for use in supported sequencers to select patchs. Currently
only Cubase VST/SX/SE/SL patch lists are supported.

Workspaces

dx.factory allows you to save a Window arrangement as a Workspace which you can then recall at a later
date.

Moving Voices within a File

When you move a Voice within a file then any Performances that reference the Voice being moved can be
updated to ensure they all still reference the correct Voices after the move.

I think you'll agree this is a cool feature!

This feature can be off if required within the Preferences Dialog.

The DX Synthesizer Window

dx.factory has a special window called the DX Synthesizer Window. This is a special window that represents
the DX synthesizer itself.

By setting up the MIDI preferences settings you can:

Automatically import data from the DX synth into this DX Synthesizer Window when dx.factory starts
up

• 

Automatically export data from the DX Synthesizer Wndow to the DX Synth when the data in the DX
Synthesizer Window is edited

• 

Exporting Cubase/Protools Patch Lists

You can export Patch lists from SYSEX files for use within either Cubase VST, Protools or Sonar.

The relevant options can be found on the File Menu under the Export option

The Number After An Operator

In the Tree View you may notice that an operator has a number included after it in brackets. This number is
the "checksum" value associated with the operator, and is included as a signature and as a simple way of
distinguishing between operators.

DX7II Support

dx.factory allows the creation of SYSEX files that can have any of the following:

Voice Bank A (01−32)• 
Voice Bank B (32−64)• 
Performances (01−32)• 

For example, you could create a SYSEX file that has just Voice Bank B.

Exporting Files to MIDI

You can export a file directly to MIDI once it is opened. If you do this, then the data being exported is also
copied to the DX Synthesizer Window.

Importing Files from MIDI

You can import directly from MIDI into a file. If you do this, then the data being imported is also copied to the
DX Synthesizer Window.
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About dx.factory
The about dialog is shown when the About ... option from the  Help Menu or the  button on the Tool Bar is
selected.

The dialog shows some basic information about the program including the version number and the registration
status of dx.factory.

It's also a chance to take a close look at the excellent Splash Graphic provided by Torus!
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Glossary
Term Definition
Child Window A window associated with an DX data file that you have opened that is used to display the

contents of the file.

Several Child Windows can be open within the dx.factory Desktop.
Clipboard A temporary storage area used for transferring data within a Child Window or between

Child Windows.
Collection A group of similar and related Objects.

For example a Voice Collection stores the 32 or 64 Voice Objects that a file can contain
Context
Sensitive Help

The ability of the help system to tailor the help being displayed according to where the user
pressed the Help key.

Context
Sensitive Menu

The popup menu that is displayed in either the Tree View or Table View that provides a set
of commands specific to the currently selected Object

Desktop The area within the dx.factory window where Child Windows can be opened
Drag and Drop The name for the mechanism that allows a use to move data by dragging it with a mouse

and dropping it at a new location.
DRAG
MODIFIER

The keyboard key that is held down to turn a Drag and Drop move operation into a copy
operation.

On the PC platform, the DRAG MODIFIER key is the CTRL (control) key
DX Synthesizer
Window

A special instance of a Child Window that doesn't display data in a file, but which displays
User data imported from the DX via MIDI

JRE Java Run−time Environment. This provides the Java environment which dx.factory needs in
order to run.

Sun Microsystems provides the JRE for PC systems, and Apple provide their own JRE for
MacOS X

MDI Multiple Document Inteface. The type of user interface used by dx.factory which allows
several Windows to be open within the main application window.

Menu Bar The area of the dx.factory Window that contains the set of menus used for accessing the
main functions provided by the application.

MIDI Musical Instrument Digital Interface. The primary means by which digital data is exchanged
in a serial form between synthesizers and computers.

Object A piece of DX data such as a Voice or Performance.
Plumstone A MacOS X specific library that provides the means by which external MIDI devices can be

accessed with the Java MIDI framework.
Reference The means by which the DX associates an Object (such as a Voice) with another Object

(such as a Performance Part). The reference provides the link between the two, and in the
case of the DX, the link is simply the number of the referenced Object.

Regular
Expression

A system by which certain character sequences are interpreted not as plain text but as
commands that can provide a tailored search for occurences of text

Status Bar The area of the dx.factory Window that is used to display status information upon the
currently selected Child Window. 

Table View A View which displays data in a file arranged in tablulated rows of data
Tool Bar The area of the dx.factory Window that contains a set of buttons to provide easy access to

commonly used commands
Tree View A View which displays data in a file arranged in a hierarchical tree structure.
View The means by which the data in a file is viewed.

A Child Window provides the view upon an DX File that you have opened.

The view can be either a Tree View or a Table View.

You can have several views open upno the same data, for example when you have split a
Child Window.

Workspace An arrange of the main dx.factory Window and Child Windows which can be saved for
subsequent recall.
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Keyboard Short Cuts
dx.factory provides many keyboard shortcuts for navigation and performing editing operations.

In general, navigating between components uses these keys:

Tab. Moves keyboard focus to the next component or to the first member of the next group of
components.

• 

Ctrl−Tab. Moves keyboard focus to the next component or to the first member of a group of
components when the current component accepts a tab (as in text fields, tables, and tabbed panes).

• 

Shift−Tab. Moves keyboard focus to the previous component or to the first component in the previous
group of components.

• 

Arrow keys. Move keyboard focus within the individual components of a group of components−−for
example, within menu items in a menu or within tabs in a tabbed pane.

• 

The shortcuts are divided into the following categories:

Keyboard shortcuts for the Desktop and Child Wndows• 
Keyboard shortcuts for Tree Views• 
Keyboard shortcuts for Table Views• 
Keyboard shortcuts for Editing within Tree and Table Views• 
Keyboard shortcuts for the Preferences Dialog• 
Keyboard shortcuts for Text Editing Fields• 

Keyboard Shortcuts for the Desktop and Child Windows

Action Keystroke Notes

New File Ctrl−N

Open File Ctrl−O

Save File Ctrl−S

Save File As Ctrl−A

Save All Files Ctrl−L

Open Workspace Ctrl−ALT−O

Save Workspace Ctrl−ALT−S

Tile Horizontally Ctrl−H

Tile Vertically Ctrl−V

Maximise Windows Ctrl−M

Restore Windows Ctrl−R

Minimise Windows Ctrl−I

Closes Child Window Ctrl−F4

Moves Child Window Ctrl−F7

Resizes Child Window Ctrl−F8

Minimizes Child Window Ctrl−F9

Switch to next Child Window on the Desktop Ctrl−F6
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Keyboard Shortcuts for Tree Views

Action Keystroke Notes

Expands current Object Right arrow

Collapses current Object, or moves focus to
Parent Object

Left arrow

Moves focus up one Object Up arrow

Moves focus down one Object Down arrow

Moves focus to first Object in Tree View Home

Moves focus to last Object in Tree View End

Moves up one view Page Up

Moves down one view Page Down

Selects all Object in Tree View Ctrl−A, Ctrl−/

Deselects all Object in Tree View Ctrl−\

Extends selection down Shift−down arrow

Extends selection up Shift−up arrow

Extends selection to beginning of Tree View Shift−Home

Extends selection to end of  Tree View Shift−End

Extends selection up one view Shift−PgUp

Extends selection down one view Shift−PgDn
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Keyboard Shortcuts for Table Views

Action Keystroke Notes

Moves up one row Up arrow
Shift−Return

Moves down one row Down arrow
Return 

Scrolls up one view Page Up

Scrolls down one view Page Down

Moves focus and view to first cell in the current
row

Home

Moves focus and view to last cell in the current
row

End

Moves focus and view to first cell in the current
column

Ctrl−Home

Moves focus and view to last cell in the current
column

Ctrl−End

Allows editing in a Category cell F2, Down Arrow

Allows editing in a Name cell. F2

Resets cell to the state it was in before it was
edited

Escape

Selects entire table Ctrl−A

Extends selection up one row Shift−up arrow

Extends selection down one row Shift−down arrow

Extends selection to beginning of table Ctrl−Shift−Home

Extends selection to end of table Ctrl−Shift−End

Extends selection up one view Shift−PgUp

Extends selection down one view Shift−PgDn
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Keyboard Editing Short Cuts for both Tree and Table Views

Action Keystroke Notes

Undo Ctrl−Z

Redo Ctrl−Y

Cut Ctrl−X

Copy Ctrl−C

Paste Ctrl−V

Find Ctrl−F

Find Next F3

Goto Ctrl−G

Insert Object INS Not allowed on Collections

Delete Object DEL Not allowed on Collections

Rename Object F4 Single Named Object Only

Initialise Object F5

List References F6 Single Named Object Only

Export to MIDI Edit Buffer F8 Single Voice or
Performance Only

Export to MIDI Memory Shift−F8 Voices or Performances
Only

Import from MIDI Edit Buffer F9 Single Voice or
Performance Only

Import from MIDI Memory Shift−F9 Voices or Performances
Only
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Keyboard Shortcuts for the Preferences Dialog

Action Keystroke Notes

Navigates through tabs Arrow keys

Moves from tab to its associated content pane Ctrl−down arrow

Moves from content pane to its associated tab Ctrl−up arrow

Keyboard Shortcuts for Text Editing Fields

Action Keystroke Notes

Moves insertion point one character to the right Right arrow

Moves insertion point one character to the left Left arrow

Moves insertion point to beginning of next word Ctrl−right arrow

Moves insertion point to beginning of previous
word

Ctrl−left arrow

Moves insertion point to beginning of field Home

Moves insertion point to end of field End

Submits text entry Enter, Return

Extends selection to beginning of line Shift−Home

Extends selection to end of line Shift−End

Extends selection one character to the left Shift−left arrow

Extends selection one character to the right Shift−right arrow

Extends selection to next word Shift−Ctrl−right
arrow

Extends selection to previous word Shift−Ctrl−left arrow
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Credits
Thanks in general to Ski, Torus, John Westwood (and his wacky humour), Fuse, John Doran, E!, Jim Attfield
and many, many others over at EX5Tech for being the most helpful gang of "virtual friends" I have ever
known.

Thanks for Yamaha for making such a great range of musical instruments.

The dx.factory PDF documentation file is created from the JavaHelp HTML files using <HTML>DOC This is a
great tool that allows me to maintain just one set of documentation files and create both online help and PDF
manual formats of the documentation.
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License
dx.factory is shareware. The unregistered version may be freely distributed.

dx.factory license files are issued to users who have registered dx.factory, to gain access to the program
features that are only available to registered users. If you have been issued with a license key you are not
allowed to distribute a license key to other users. Please respect this, and the amount effort I have put into
making this application.

The Author retains the copyright on the program and its features.

dx.factory cannot be included as part of a commercial distribution or on other web sites without the express
permission of the Author. I am happy for you to provide links to www.xfactory−librarians.co.uk, to maximise
public access to dx.factory.

Disclaimer
Like all software products, this software is provided "AS IS", and without any warranties expressed or implied.
But hey, remember, you're getting it at very low cost for what I consider to be a commercial quality application.

I have worked hard to ensure this software works correctly, as I certainly don't want it trashing my data.
However, I cannot be held liable for any problems arising as a consequence of you using this software on
your computer and your data. You use this product at your risk.

Like all new products, please proceed and evaluate with care, and ensure that all your important data files are
backed up before installation and evaluation.

Having gotten that out of the way, if you do encounter any problems, please submit a bug report to
dx7@xfactory−librarians.co.uk, and I will endeavour to provide a fix for any reported problems.
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